2004 MITSUBISHI ENDEAVOR User Comment / Complaint

2004 MITSUBISHI ENDEAVOR User Comment / Complaint

HOME » M » MITSUBISHI » ENDEAVOR » 2004 » Manifold/header/muffler/tail pipe » comment/complaint
  • Error getting parent threads
2012-11-02 10:09:12 pennsylvania

Hey Michigan,did you ever find out why your Mitsubishi starts loud and goes away after it warms up?I have the same problemat 123,000 miles and it started about 5,000 miles ago.Cant seem to get any answer from a mechanic,by the time I get it there for the noise they cant find nothing wrong.Now recently my service engine soon light came on but there seems to be nothing wrong.

Send us your comment

Email
change MITSUBISHI
Comment Requirements
Email
* Required - We will send a verification link to this email before your comment is posted.
Password
Optional - If you leave many comments and do not want to verify each one individually, put a password in this field. Your first comment will still need to be verified, but after it has you will be able to post comments immediately without having to wait for the verification email from our servers.
Location
Optional - City & State if you live in the US or Canada, City & Country if you live anywhere else
Make / Model / Year
* Required
Image Form Verification
* Required
Password
change ENDEAVOR
Location
change 2004
Comment    Max Characters: 1000 -- Remaining: 1000
Security Image Enter letters from box to the left
   
comments/
Keywords:
MITSUBISHI ENDEAVOR Comments and Complaints,MITSUBISHI ENDEAVOR Comments and Complaints ID:8400 Safety Comments and Complaints MITSUBISHI ENDEAVOR, MITSUBISHI ENDEAVOR Vehicle Safety Comments and Complaints, Comments and Complaints MITSUBISHI ENDEAVOR, MITSUBISHI ENDEAVOR Comments and Complaints

Page Description:
MITSUBISHI ENDEAVOR Comments and Complaints ID:8400 - Vehicle Safety Comments and Complaints Information for MITSUBISHI ENDEAVOR

Quick Find

 




Home  |  Vehicle Recalls  |  Service Bulletins  |  All World B2B