2000 LEXUS RX300 User Comment / Complaint

2000 LEXUS RX300 User Comment / Complaint

HOME » L » LEXUS » RX300 » 2000 » Automatic transmission » comment/complaint
2007-08-30 00:00:00 Encinitas, CA

2000 lexus rx300 transmission failure failed at 79,780 miles and the replacement failed after 140 miles! the consumer stated engine revs okay but no power to wheels. the consumer stated had vehicle repaired at dealer and the dealer stated the transmission solenoid failed.

Send us your comment

Email
change LEXUS
Comment Requirements
Email
* Required - We will send a verification link to this email before your comment is posted.
Password
Optional - If you leave many comments and do not want to verify each one individually, put a password in this field. Your first comment will still need to be verified, but after it has you will be able to post comments immediately without having to wait for the verification email from our servers.
Location
Optional - City & State if you live in the US or Canada, City & Country if you live anywhere else
Make / Model / Year
* Required
Image Form Verification
* Required
Password
change RX300
Location
change 2000
Comment    Max Characters: 1000 -- Remaining: 1000
Security Image Enter letters from box to the left
   
comments/
Keywords:
LEXUS RX300 Comments and Complaints,LEXUS RX300 Comments and Complaints ID:8415 Safety Comments and Complaints LEXUS RX300, LEXUS RX300 Vehicle Safety Comments and Complaints, Comments and Complaints LEXUS RX300, LEXUS RX300 Comments and Complaints, Vehicle Comments and Complaints LEXUS RX300, LEXUS RX300 Comments and Complaints Vehicle

Page Description:
LEXUS RX300 Comments and Complaints ID:8415 - Vehicle Safety Comments and Complaints Information for LEXUS RX300

Quick Find

 




Home  |  Vehicle Recalls  |  Service Bulletins  |  All World B2B